[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: System hang during write of large files



Hello Janne,
nice to not be alone ...

We did some things during the last accident:
- Changed the alive time of buffer to 3 seconds from 30
- Started the wakeup of the kupdate daemon every 0,6 seconds
These both things are described in
http://www-106.ibm.com/developerworks/library/l-fs8
(search for the work kupdate)

We also changed from data=ordered to data=journal (seems to be better for database usage).

We did not tested since the changes where made because some persons are working on the machine (and after working a few weekends in a line I got a little bit tired).

Annother try worth in my eyes would be a bigger journal. Our current journal is 33 MB on a 40 and a 60 MB disk. If its a journal overflow may be 500 MB will solve the problem.

As I understand from your mail it is not a kernel problem of kernel 2.4.10.

Klaus


Janne Pikkarainen wrote:
As we tried 3 of these extents in one run of the extent utility, the system hangs without any error message. The master console was also dead; we could enter root but the password prompt never comes up.


Wow. Sounds just like the problem we currently have with one of our servers
running Red Hat 7.2. It's hard to say if it's really an ext3-related problem but anyway the server freezes whenever it wants to do it. The same symptoms than above - login prompt allows me to enter root but the password prompt never appears. If I'm already logged in, I may be able to use commands which are already loaded in memory. Stuff which has to be loaded from hd never loads.


Physically the server seems to be blinking it hard drive lights as normally.

And the server...

- IBM xSeries 330
- Red Hat 7.2
- 1 GB RAM
- 200 GB HD w/ ext3
- IBM ServeRAID 4M
- 2x Adaptec 7899P

The latest Red Hat cooked kernel I tried (2.4.9-21) gives something like 1-6 hours of uptime. My own home-cooked and salted kernels are able to run our server something like 10-40 days before crashing, no more. At least not yet. :-) The latest kernel I have compiled myself is 2.4.18-pre9 and it's having the same symptoms...




_______________________________________________ Ext3-users mailing list Ext3-users redhat com https://listman.redhat.com/mailman/listinfo/ext3-users








[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]