[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Ext3 -> Ext2 ?



On Feb 22, 2002  19:00 +0100, Dr.-Ing. Torsten Finke wrote:
> I tried to setup my linux box with an ext3 root file system. 
> That failed because of wrong initrd settings. Sorry. 

Yes, a common problem.

> Now the filesystem is marked having a journal but there
> is no /.journal file anyway. I tried to buikd that 
> journal by hand (tune2fs -j /dev/hda3 - in my case). 
> That fails also. :-(
> 
> /sbin/tune2fs -l /dev/hda3 
> 
> says:
> 
> ...
> Journal UUID:             <none>
> Journal inode:            8
> Journal device:          
> 0x0000                                                             
> ...
> 
> How could I convert an Ext3 down to an Ext2, so having the 
> chance to work by hand? 

You are using SuSE with 2.4.10 kernel?  It is broken when creating a
journal on a mounted filesystem.

To remove the existing journal "chattr -i /.journal; rm /.journal".
To create a new journal you either need to boot to another kernel
version, or boot from a CD or floppy, and "tune2fs -j /dev/hda3".

Cheers, Andreas
--
Andreas Dilger
http://sourceforge.net/projects/ext2resize/
http://www-mddsp.enel.ucalgary.ca/People/adilger/





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]