[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: hardware error or fs corruption?



On Tue, 26 Feb 2002, Mohammad A. Haque wrote:

> Michael
>
> Thanks for the quick response. Will do your suggested test.
>
> I was reading the logs some more and found this and was about to email
> the list before getting your response. Just as another data point.
>
> Feb 26 04:14:07 viper kernel: hde: dma_intr: status=0x51 { DriveReady
> SeekComplete Error }
> Feb 26 04:14:07 viper kernel: hde: dma_intr: error=0x40 {
> UncorrectableError }, LBAsect=47976575, sector=47976512
> Feb 26 04:14:07 viper kernel: end_request: I/O error, dev 21:01 (hde),
> sector 47976512
> Feb 26 04:14:07 viper kernel: EXT3-fs error (device ide2(33,1)):
> ext3_readdir: directory #2998273 contains a hole at offset 0
>
>
> I'm assuming the root of the problem is the same since the error code is
> the same and the readdir problem is caused by that.
>
> Anything I should kick back to the list should turning off UDMA make the
> error go away?

Hi Mohammad!

I noticed various IDE/DMA errors when activating UDMA on IDE Devices whose
controllers drivers were not included in the kernel. These errors usually
show up immediately after activating UDMA when you stress the filesystem a
bit (e.g. unpacking a kernel). If your server ran flawless the last
weeks/months/years with udma activated its most likely a harddrive error..

best regards,
Michael Renner





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]