[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EXT3-fs error



Hi,

On Mon, Jan 21, 2002 at 01:38:55PM +0100, Martin Eriksson wrote:
> 
> > On Sun, Jan 20, 2002 at 05:56:48PM -0800, Louis Hopcraft wrote:
> > > No matter what I do (Y or N) the results are the same.  The problem will
> > > not go away.  Does anyone have any ideas as to a fix, or to what the
> > > problem is?  When I do a fsck and it marks the fs as clean I reboot and
> > > hdb: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> > > hdb: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=81423,
> >
> >   Your IDe drive is dying. backup immediately and try to get the warranty
> > to apply.
> 
> This can also be because of IDE drives running out of spec, ie. having an
> overclocked PCI bus, a buggy drive or a buggy controller. One of my drives
> exhibited typical "bad sector" behaviour, when in fact the drive couldn't
> run on it's rated UDMA33 speed and had to be manually tuned for MW-DMA2.
> (Now I run with Andre's IDE patch which automatically tunes "down" the drive
> because it is in som "quirk" list or something).

The error was "SectorIdNotFound", which is a specific message coming
back from the drive that the sector header on the platter was not
present.  DMA problems can manifest themselves as all sorts of data
corruption failures, but this is not such an error.  I very much doubt
it's anything other than a drive fault.

Cheers,
 Stephen





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]