[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ext3, S/W RAID-5 and many services



Hi TJ,

Thanks for all that input. I am not yet very litterate with all the internals of the kernel, and about the tools to diagnose this.
I also figured out that the 3c59x modules was constantly in the Ooops and other messages reportings from the kernel.
That machine having 2 network cards, I switched to the other, and I do have less problems. It is a VIA network card (via-rhine kernel driver).
I will have to make a few stress tests which this card, as I had other problems while recovering from the messed-up file system.


Is there some work for the 3c59x driver to fix these ? Or are these network cards considered obsolete ?

Pascal

TJ wrote:

I am having the exact same problems with my linux box.

   I have a 486, 24Mb of ram, and a RAID 1 partition. The box runs
dhcp, xinetd, telnetd, and samba. It currently only serves the RAID 1
partition via samba to a single Win98 box.
Under any large file transfer to the linux box, regardless of which
machine initiates the x-fer, the linux box kernel panics and dies.
Currently, I have tried running many kernels, upgrading to a different
glibc and rawhide kernel, and even scrapped RH and made an LFS
partition. I have also used multiple versions of samba and I have tried
using 3com's driver instead of the kernel driver. Nothing has fixed this
problem. Recently, I thought the network load was filling the physical
memory because the error was usually a "Unable to handle kernel virtual
memory paging request," however, I have tried both stock kernels and RH
kernels with the rmap VM system and both crash. I also increased
/proc/sys/vm/freepages to such large numbers that there was always over
a meg of free mem while a file transfer was going, but the box still
crashed.
   The stack dump used to be from many different programs, but, after I
increased freepages, it seems to always be from the 3c59x module. I have
tried 3com's driver instead. It held up better under load, but still
crashed after about 15 minutes of file transfer via samba.
   I do not believe this is a RAID problem as I get the same problem
with RAID turned off and sharing a regular non-RAID directory with
samba.
   I now feel that, because two seperate drivers fail, this must be
some issue with the hardware. As I just found this problem and it seems
as if you have 3com card in the same family as mine, I am very confidant
now. If you search the mail list archives for the 3c59x driver, you will
find this problem many times over. I don't yet know the solution, but,
if you can, you might try a different networking card. I am going to
switch out the NIC cards between my Linux box and Win98 box and see how
that does. Hopefully it's not an issue between the two cards.









[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]