[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ext3 on Linux software RAID1



Hi,

On Sat, Mar 02, 2002 at 06:32:01PM -0800, Andrew Morton wrote:
> Matti Aarnio wrote:
> > 
> > How much the problem lies in the gcc version (RH 7.1 2.96-97.1), and
> 
> A dog of a compiler.  Burn it.  I had a machine which oopsed
> mysteriously once a day somewhere down playing with swapspace ptes.
> Compiling that kernel with 2.91.66 fixed the problem.

<sigh>

There hasn't been a compiler since as long as I can remember which
hasn't broken the kernel in at least one of its incarnations.
gcc-2.96-97.1 should be solid for the kernel.  At least one older
release of 2.96 was broken in nasty ways.  If I can show you a version
of 2.91 which breaks the kernel, will you forswear 2.91.66 too?  :-)

Bero has some notes on http://www.bero.org/gcc296.html

--Stephen





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]