[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

High load on Squid server after change from reiserfs to ext3



We are running Zope behind Squid 2.4Stable6 with squid in acceleration mode.
The squid box (dual Pentium III 1 GHz, RH 7.2, Linux 2.4.9-21smp, 2GB Ram)
has during busy hours a normal load of 0.2-0.3 . From time to time
we see spikes over some hours where the load average of the machine
is higher than 1.5 although there are no spikes in the CPU
utilization. Also there is no increase in the number of incoming requests.

The only change we made was the switch from reiserfs to ext3 for the cache
partition since reiserfs corrupted its partition some time ago.

After migrating a second box (same hardware) to ext3 this box show the same
odd behaviour.

Both boxes sit behind a loadbalancer and receive the same number of requests
each. There is connection between the spikes on both machine. One machine
idles
almost while the other has a load >2.0 Looking at Squid internal statistics
show that the requests are equally distributed between both servers.
There are also no other services running runing the boxes.

Any insights on this issue?

Thanks,
Andreas



    ---------------------------------------------------------------------
   -    Andreas Jung                            Zope Corporation       -
  -   EMail: andreas zope com                http://www.zope.com      -
 -  "Python Powered"                       http://www.python.org     -
  -   "Makers of Zope"                       http://www.zope.org      -
   -            "Life is too short to (re)write parsers"               -
    ---------------------------------------------------------------------






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]