[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Problem recovering ext3 filesystem



On Sun, 2002-11-17 at 18:36, Arthur Perry wrote:
> That being said, I would  boot from a rescue disk (if this is also your root
> filesystem), mount the bad drive with "mount -t ext2 /dev/hdc3 /mnt/drive -o
> ro" and then copy your data which hopefully is not damaged, to the new mount
> drive which you just have prepared and mounted for this exercise.

Hello Arthur,

First of all, thanks a lot for your reply. Your guess was right. Indeed
that drive had been in production on a server until I discovered it was
damaged. The next day I got two new drives and I set them in raid - I
should have done this long before ;). I reinstalled the machine and
restored my backups.

The damaged drive is now installed in a workstation as a secondary
drive, so there is no need to use a rescue disk (I have a full
functional linux on the workstation's primary drive). And (again, you
were right) I only want to read some files that were too large to backup
(in fact it's a file hash - many files in many directories, which are
located, in their turn, in other directories). I don't need to repair
the filesystem, nor do I intend to use the damaged drive any more.

My biggest mistake was to shut down the server when I noticed the error
messages from the kernel. Hadn't I shut it down, I could have transfered
those files through the network to another machine, as the partition was
still mounted.

The problem is that the group descriptors following the main superblock
are broken. So the filesystem won't mount - either as ext2 or ext3.
That's why I began playing around with e2fsck. I made a (linear) backup
of the whole filesystem because I was afraid e2fsk would make a bigger
mess out of the filesystem.

Recreating the journal didn't work. The new journal seems to be placed
(partially, at least) in the same inodes as the old journal. Since the
disk is physically damaged in those locations, creating a new journal
ends up with error messages and a failure.

I'm not sure, but I guess the group descriptors are replicated in each
block. I could try copying one of the backups over the main copy of the
group descriptors. Then I could try to mount the filesystem. Did anyone
try this? Is there any chance to be able to mount the filesystem
aferwards?

Radu Rendec






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]