[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

File System corruption



Hi,
Yesterday I nuked an old fat32 partition on my hard drive using fdisk. I
just destroyed the partition and then created a new linux partition. Then I
created an ext3 filesystem with the following command

mkfs.ext3 -j /dev/hdc1

Everything seemed fine so I went ahead and moved all my music (MP3s and
FLACS) onto that partition.
This morning when I turn on my computer I can't mount that partition! It
just says it can't read the superblock. Nor can fsck read the superblock.
Just to make sure that I had the correct device etc. I tried

dd if=/dev/hdc1 of=tmp.file

and killed it when the file got to about 200MB. I quickly loaded the file
into vim and had a glance through it and sure enough I could see some of
the names the songs and artists - they were probably the playlist files.
Is there anyway I can recover this filesystem? I've tried using debugfs and
recover but they both complain that they can't open the filesystem. It
looks like that these tools are useful for undeleting files and not for
recovering filesystems.
I'm pretty sure its not a hardware related problem (I've never had any
problems with this disk before and there are no errors in the system log).
The output of fdisk is

Code:

Disk /dev/hdc: 46.1 GB, 46115758080 bytes
255 heads, 63 sectors/track, 5606 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
   Device Boot    Start       End    Blocks   Id  System
   /dev/hdc1             1      2295  18434587   83  Linux
   /dev/hdc2          2296      4207  15358140   83  Linux
   /dev/hdc3          4208      5542  10723387+  83  Linux
   /dev/hdc4          5543      5606    514080    f  Win95 Ext'd (LBA)
   /dev/hdc5          5543      5606    514048+  82  Linux swap


And
   mount -t ext3 /dev/hdc1 /audio
gives
   mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
          or too many mounted file systems 

I'm running a 2.4.20 kernel and I'm aware (now) of the ext3 filesystem bugs
- this kernel wasn't patched with the bug fixes. Is it possible that one of
  the bugs did the damage? Is there anything I can do about it?

Any thoughts or suggestions would be greatly appreciated,

Mark Phalan





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]