[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: mount: error 22 mounting ext3



On Thu, 2003-05-01 at 17:36, Andrew Chen wrote:
> I am unable to boot my original RH 9 with the RH 7.2 drive installed. If I
> disconnect the  the drive (RH 7.2 w/ ext2), then RH 9 boots up fine.
> 
> The RH 7.2 drive used to be the boot drive for another system. Now I just
> want to use it as additional storage in my RH 9 system. Hope this clarifies
> my system problems.

RH uses labels to identify partitions to mount (rather than using device
names), so you will tend to have something like:-

  LABEL=/usr   /usr  ...

instead of

  /dev/hda6	/usr ...

in your fstab (NB I might have got the syntax a little wrong in the
first one - I don't use labels myself).

The labels applied to the partitions by the installer are directly
related to the mount point the filesystem would use.   So if you are
reusing a drive from another installation you may well have the same
label on 2 partitions on different drives, with "interesting" results.

Easiest fix is probably to replace the labels in fstab with hardwired
device names.  Alternative is to use e2label to modify the labels used -
or just repartition the drive you have imported.

	Nigel.
-- 
[ Nigel Metheringham           Nigel Metheringham InTechnology co uk ]
[ - Comments in this message are my own and not ITO opinion/policy - ]





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]