[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: tune2fs -j on mounted FS



On Sat, Nov 01, 2003 at 02:58:28PM +0000, Sean Neakums wrote:
> I tried reproducing this on my laptop, which also had an ext2 root and
> was also running 2.6.0-test8.  I ran the tune2fs -j (same version and
> source as above) and updated /etc/fstab as before.  Nothing seemed to
> be breaking, so I went ahead and built 2.6.0-test9 in my homedir,
> which is on a separate volume (/ and /boot are regular partitions;
> /home, /usr and /var are lvm2 volumes.  The other box has a similar
> configuration.).  When I ran make modules_install, messages of the
> following form began streaming on the console:

It is a brave man that uses 1K block filesystems with stacked devices;
even /boot is 4K blocks on my machines. ;-p

You might want to try the latest DM patches from Joe Thornber's
site,

 http://people.sistina.com/~thornber/

and consult the dm-devel mail list archives.  There have been
a fairly steady stream of DM patches.  Note that there is a small
problem in 2.6.0-test9-dm3; the fix from Kevin Corry is below; see
the dm-devel archives.

Use s->chunk_size instead of chunk_size. The latter was modified earlier in
snapshot_ctr.

--- a/drivers/md/dm-snap.c	29 Oct 2003 15:58:59 -0000
+++ b/drivers/md/dm-snap.c	31 Oct 2003 17:37:00 -0000
@@ -527,7 +527,7 @@
 	}
 
 	ti->private = s;
-	ti->split_io = chunk_size;
+	ti->split_io = s->chunk_size;
 	return 0;
 
  bad6:

I haven't had a chance to try it out myself.

Regards,

    Bill Rugolsky




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]