[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: warning: updated with obselete bdflush call



Hi,

On Thu, 2004-03-04 at 10:50, David Baron wrote:
> Get this warning on bootup ext3 file checks on 2.6.* kernels.
> 
> Apparently harmless, but how do I fix this?

bdflush isn't needed on 2.6 at all.  The message you get just after that
error in the logs is

		printk(KERN_INFO "Fix your initscripts?\n");

which gives you a clue how to fix it: it's a matter of getting the init
scripts not to try starting the bdflush daemon in the first place.

But bdflush is a noop on 2.6, it's harmless to leave things as they are
for now in case you want to dual-boot between 2.4 and 2.6.

--Stephen





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]