[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PROBLEM: log abort over RAID5



Em Fri, 05 Mar 2004 17:18:05 +0100, Bodo Thiesen escreveu:

> 1. Check if the hard disk has bad blocks.
> 
> # badblocks -b <ext3blocksize> <ext3device>
[...]
> 2. Umount the filesystem
> 
> 3. Run e2fsck
> 
>    If that fails, report it here and don't continue ;-)

	I did both steps in one, with e2fsck -cc on all LVMv2
partitions, both ext3 and ext2.  No errors.


> 4. Try to remount the filesystem as ext3.
> 
>    If that works, you should be done.

	Yes, it works, but it has always worked.  After I get the
abort log, I always can reboot the system, get lots of seemingly minor
corrections, and continue work for one or two days, perhaps almost a
week.  Then I get another abort log, one filesystem remounted
read-only, and have to reboot again.
	

> 5. If that doesn't work then:
> 
>    Report the error messages here. You may continue or wait for answers
>    ...
> 
> 6. disable usage of journal: tune2fs -O ^has_journal <ext3device>
> 
> 7. mount the file system as ext2 and update /etc/fstab according to that.

	In the off chance e2fsck -cc will have done any good, will try
to run the system on ext3 a few days more.  If all continues the same,
I will report the errors here and go back to ext2.

	Be aware this error has been seen by more than poor me.  If
anyone needs any information more to be able to reproduce and
troubleshoot, please feel free.


-- 
Leandro Guimarães Faria Corsetti Dutra           +55 (11) 5685 2219
Av Sgto Geraldo Santana, 1100 6/71               +55 (11) 5686 9607
04.674-000  São Paulo, SP                                    BRASIL
http://br.geocities.com./lgcdutra/




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]