[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

cp weird behaviour, some copied files differ from original.



Hi.
I know that for the problem that will follow many things other than ext3 are involved, like a kernel upgrade, a possible coreutils mis-behaviour and other, so I beg your pardon if I'm not in the right place ...


Now the problem. I have met a trouble upgrading web/dns server running linux.
Precisely, I have upgraded the kernel from 2.4.9 to 2.6.6 and the hard disk also, from 20Gb to 80Gb.
Ok for the kernel, all is ok.


Problems came out with hard disk upgrade. I followed the "Hard Disk Upgrade Mini How-To" (http://www.tldp.org/HOWTO/Hard-Disk-Upgrade/).
After the copy of files from the old disk (ext3) to the new one (ext3 also, but with larger partitions) some problems arose.
In fact the command to compare the two disks after the copy, find / -path /proc -prune -o -path /new-disk -prune -o -xtype f -exec cmp {} /new-disk{} \;
tells that there are some differences in some files.


Looking with vi I saw that it's true indeed.. Some characters are different! Example, in a log file, there is a line where a '1' become a 'y' in the word 'May', and so on.
Manually replacing the "corrupted" file with the original one and running again the find command I have that other files differ. And running again, all seems to be ok..
The behaviour is quite umpredictable :\


I have copied some hundreds of thousand of files, and just a little percentage seems to be "damaged", but I need to know the cause of this fact.

Can you help in some way?

Thaks for any reply,
Paolo

P.S. I ran memtest and hard disk diagnostic, hardware results to be ok.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]