[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HD Partition Lost??

evilninja wrote:

Hash: SHA1

Steve Watford schrieb:
| Thanks,
| I'll give dd a try for backup puposes. I have already tried to fsck
| the
| partition it just comes back with a short read error.  Asking if it is
| a zero

always be careful to check an already damaged disk:

| Steve Watford schrieb:
| | hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
| | hda: dma_intr: error=0x40 { UncorrectableError }, LBAsect=90895772,

being not a professional but a normal user i think this really looks
like some hw issues. so i'd suggest better to copy (dd) all the data
from the disk, as long as you have time to. every additional use of the
disk may cause its final death.

i wonder why your other partitions *seem* to still be ok (e.g. "mount"
and using its data then succeeds)...

Ack! I've had too many failures with Maxtor disks.

Anyway, use conv=sync,noerror with your dd command, preferably to an identical disk. Do the entire disk /dev/hda. Yes, it will take a very long time, but you have no other recourse if you want maintain all your data. Then fsck the new disk. Fsck on the bad disk may just make matters worse.

Download Maxtor's ide utility & see if you can fix the bad one - may require a total disk rewrite.

Nothing unusual about the other partitions being okay - just a matter of location of the sectors on the platter(s). Be suspicious of the entire disk though.

Toby Bluhm

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]