[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: bad inode number followed by ext3_abort and remount readonly



On Tue, Jun 14, 2005 at 07:19:23PM -0400, Andreas Dilger wrote:
> On Jun 14, 2005  17:14 -0400, David Shaw wrote:
> > Jun 13 13:58:16 n202 kernel: EXT3-fs error (device sda5): ext3_get_inode_block: bad inode number: 9
> > 
> > This particular example is a SATA disk, but it has happened to a
> > regular old IDE disk as well.  It is always the root partition.  The
> > bad inode number varies (but is always either 3 or 9).  There are no
> > other errors about the disk in the log.
> 
> The "bad inode number" check is only for inodes inside the "reserved inode"
> area, namely inum < 12.  The only commonly used (=valid) inode numbers in
> this range are the root inode (=2) and the journal inode (=8), so I suspect
> you are getting single-bit memory errors in bit 1, or if the controller
> is the same that would also be viewed with suspicion.  It is very likely
> that you are getting other single-bit errors elsewhere but they are harder
> to notice.

This is an interesting idea.  Is there any simple way this sort of bit
flip problem could happen outside of the hardware?  I've had this
happen on 4 different machines from 3 different vendors, 3 SATA, and 1
IDE.  It seems almost impossible that it's a memory or controller
error.

David


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]