[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: failure in do_get_write_access() at transaction.c:731: "(((jh2bh(jh))->b_state & (1UL << BH_Uptodate)) != 0)"



Hi, Christian:

Thanks for the information. 
The problem is not easily reproducible but I have noticed that somebody had raised the same issue before (http://www.redhat.com/archives/ext3-users/2002-May/msg00052.html). 

I know that the kernel version I am currently running is too old. However, since it is running on the legacy product, it is not easy to convince the customer to do the upgrade.

If you can point me to where the fix is, I will probably just get the fix and replace the file(s) while keeping running 2.4.19 kernel.

Once again, thank you for your time and knowledge.


Joe

-----Original Message-----
From: Christian [mailto:evilninja gmx net]
Sent: Monday, August 14, 2006 2:56 PM
To: Zhao, Joe
Cc: ext3-users redhat com
Subject: Re: failure in do_get_write_access() at transaction.c:731:
"(((jh2bh(jh))->b_state & (1UL << BH_Uptodate)) != 0)"


On Mon, 14 Aug 2006, Zhao, Joe wrote:
> By running some scripts on our target system for a while, I lost all means of access to the system.
> It seems that the kernel is crashed with the following error message:
> Assertion failure in do_get_write_access() at transaction.c:731: "(((jh2bh(jh))->b_state & (1UL << BH_Uptodate)) != 0)"
> Oops: Exception in kernel mode, sig: 4

is it reproducible? if not, did the fs suffer corruption? did e2fsck 
report anything? if yes, read my comment below:

> We are currently running Linux version 2.4.18.
> I assume that the problem has been fixed.

whatever the problem is: I'd like to hear the reason to run such an old 
kernel, 2.4.18 has been released early 2002, you know ;)

if you can, please upgrade to 2.4.33.

Christian.
-- 
BOFH excuse #11:

magnetic interference from money/credit cards


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]