[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: failure in do_get_write_access() at transaction.c:731: "(((jh2bh(jh))->b_state & (1UL << BH_Uptodate)) != 0)"



Hi, Christian:

I really appreciate your help. 
How do I know the fix is indeed included in 2.4.20 if I want to upgrade from 2.4.18 to 2.4.20? I did dig a bit for the release note of 2.4.20 but I couldn't find anything related to the problem. 

Stephen:
Can you provide me more information regarding to the fix?

Thanks.

Joe

-----Original Message-----
From: ext3-users-bounces redhat com
[mailto:ext3-users-bounces redhat com]On Behalf Of Christian
Sent: Monday, August 14, 2006 5:13 PM
To: ext3-users redhat com
Subject: RE: failure in do_get_write_access() at transaction.c:731:
"(((jh2bh(jh))->b_state & (1UL << BH_Uptodate)) != 0)"


On Mon, 14 Aug 2006, Zhao, Joe wrote:
> The problem is not easily reproducible but I have noticed that
> somebody had raised the same issue before
> (http://www.redhat.com/archives/ext3-users/2002-May/msg00052.html).

thanks for the link, that really should clear up some things:

Andrew Morton replied in [0] and pointed to a ext3-cvs.patch. 
Unfortunately it's not there any more: try to contact him where this 
file has moved to or try the wayback-machine [1] when it's back online.

Another reply [2] from Stephen Tweedie explained this in depth, 
mentioning 2 fixes:

1) a missing "goto repeat", this should be this patch:
    http://sourceforge.net/mailarchive/message.php?msg_id=5105906

2) something involing parallel blockdevice IO/fs IO. However, I could
    not spot the right patch on the ext3 CVS commit list [3]. Maybe
    the ext3 developers remember...

That, or someone with the lost ext3-cvs.patch should do it.

> I know that the kernel version I am currently running is too old.
> However, since it is running on the legacy product, it is not easy
> to convince the customer to do the upgrade.

4 years of begging to update their product to the present 
state-of-technology, wow ;)

> If you can point me to where the fix is, I will probably just get
> the fix and replace the file(s) while keeping running 2.4.19 kernel.

Although Andrews patch was in ../2.4/2.4.19-pre8/ext3-cvs.patch, he 
said:

> Stephen has a fix in ext3 CVS for this.  I've been playing with that
> fix in 2.5.x.  I guess we'll slot it into 2.4.20-pre.

would it be possible to "upgrade" to 2.4.20?

Christian.

[0] http://www.redhat.com/archives/ext3-users/2002-May/msg00053.html
[1] http://www.archive.org/web/web.php
[2] http://www.redhat.com/archives/ext3-users/2002-May/msg00058.html
[3] http://sourceforge.net/mailarchive/forum.php?forum=gkernel-commit
-- 
BOFH excuse #70:

nesting roaches shorted out the ether cable

_______________________________________________
Ext3-users mailing list
Ext3-users redhat com
https://www.redhat.com/mailman/listinfo/ext3-users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]