[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

needs help, root inode gone after usb bus reset on sata disks



Hello everybody,

I am new to this list, so welcome everybody.

Last 2 week I had two harddisk crashes with my ext2 file system.

This is what sort of happed with both of the disk:

I pluged in my USB to SATA converter in my harddisk that has an ext2
filesystem. I mounted the partition, went to a directory that had a DVD
image. I mounted the dvd image in the same directory and started
watching the movie. After 40 minutes the movie stops.

After some investigation I saw the ISO image was not mounted anymore.
And dmesg was showing 3 USB bus reset log entries.

I rebooted the computer and tried to mount the usb ext2 disk partition
again. But it failed.

dmesg and a fsck showed messages about the root inode being gone!

fsck.ext2 -p /dev/sdd1 did not work manual run is needed.

On the first 500GB disk I did an fsck.ext2 -y /dev/sdd1 did did not
fixed my disk it had still errors, I lost 35% of my data, but the
partition was mountable again, and the files where in the lost+found
directory.

I don't want this to happen with the second 750GB harddisk, I would like
all my data back.

fsck.ext3 -n /dev/sdd1 > fsck-crash-info.txt 2>&1
http://filebin.ca/mczmks/fsck-crash-info.zip

What should I do? What commands do you want me to run to provide more
info? How can i restore my root inode?

Thanks in advance,

Jelle de Jong


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]