[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ext4 and unexpected eh_depth



On Wed, Feb 04, 2009 at 10:41:32AM +0200, Markus Peuhkuri wrote:
> Hi, I'm running Debian lenny with linux-image-2.6.26-1-amd64  (deb
> 2.6.26-11).  I have a lvm stripe over three sata disks (3.5TB total)
> that is shared over NFS, and I getting following errors
> 
> EXT4-fs error (device dm-0): ext4_ext_search_right: bad header in inode #269200: unexpected eh_depth - magic f30a,entries 18, max 340(0), depth 1(2)

I can't recall the patch which fixed this, but I'm 95% certain we've
seen this before, and it's been fixed since 2.6.26; I think in 2.6.27
or 2.6.28.  Note that there have been a *huge* number of bug fixes for
ext4 since 2.6.26 and 2.6.27.  If you must use such an old kernel I'd
suggest moving to at least 2.6.27.x or 2.6.28.x after Greg pulls in
the latest set of bug fixes.  Critical bug fixes are still being back
ported to 2.6.27.x, although you won't see various performance
improvements unless you track a much newer kernel.  I'd suggest at
least 2.6.28.y at this point.

						- Ted


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]