[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

damaged encrypted LUKS device



Hi people,

i had created encrypted device with cryptsetup/LUKS which i setup with an ext4 filesystem. This device is an external USB harddisk. When i plugin this device it will be automatically mounted by my gnome3 system (Debian Wheezey/Testing), but this week i got an error. I did ask the ask the LUKS developers what is the problem and they told me that this is an ext4 problem.

The error message from gnome is:
Einhängen von AIRY_1TB nicht möglich

Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/mapper/udisks-luks-uuid-70a2aedf-ce7e-4e12-8f0b-ec7974ebdbd4-uid1000,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so




And from <dmesg> i got the message:
[ 3094.394043] EXT4-fs (dm-0): ext4_check_descriptors: Inode bitmap for group 3328 not in group (block 1235654634)!
[ 3094.394056] EXT4-fs (dm-0): group descriptors corrupted!

Further on, when i try to <fsck -N /dev/sdb> i get:
fsck from util-linux 2.19.1
fsck: fsck.crypto_LUKS: not found
fsck: Error 2 while executing fsck.crypto_LUKS for /dev/sdb

But cryptsetup is installed, only lvm2 is missing, but i dont have a LVM device and as i researched at "debian.org" there is no package which provides the command <fsck.crypto_LUKS>.


Any hints/instructions for me?

regards Markus


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]