[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

power outage turned raid ext3 into ext2, how to fix ?



Hi all,

after a power outage the raid5 /dev/md2 couldn't be assembled,
mdadm -Af (forced assemble) worked,
and i can access all the data when i mount it as ext2,
but it used to be ext3 before and i get errors trying to mount it as that.

after it couldn't be assembled directly (sorry, didn't save the original error message)
i found the right drives using
# mdadm --misc --examine /dev/sdX
and used
# mdadm -Af /dev/md2 /dev/sdd1 /dev/sde1 /dev/sdf1 /dev/sdg1 /dev/sdh1 /dev/sdi1
(-A assemble, f:forced) and it worked saying
# mdadm: forcing event count in /dev/sde1(0) from 51014 upto 51020
# mdadm: forcing event count in /dev/sdf1(1) from 51014 upto 51020
# mdadm: forcing event count in /dev/sdg1(2) from 51014 upto 51020
# mdadm: forcing event count in /dev/sdh1(3) from 51014 upto 51020
# mdadm: forcing event count in /dev/sdi1(4) from 51014 upto 51020

Now when i mount it (i only tried readonly for now) as ext2 it works fine, i can see the files etc, but it used to be ext3, and when i try to mount it as that i get errors, so something is wrong.

mdadm --misc --examine reportet status clean and correct checksums (i checked before doing forced assemble)
smartctl -H on the physical drives reports they all pass the health-check
# mount -o ro -t ext2 /dev/md2 /media/mytest
works fine, after that umount and
# mount -o ro -t ext3 /dev/md2 /media/mytest
reports :
# mount: wrong fs type, bad option, bad superblock on /dev/md2,
#        missing codepage or helper program, or other error
#        In some cases useful info is found in syslog - try
#        dmesg | tail  or so

fsck.ext3 /dev/md2 reports :
# fsck.ext3 /dev/md2
# e2fsck 1.41.3 (12-Oct-2008)
# /dev/md2 contains a file system with errors, check forced.
# Pass 1: Checking inodes, blocks, and sizes
# Journal inode is not in use, but contains data.  Clear<y>?
#
# /dev/md2: e2fsck canceled.
#
# /dev/md2: ********** WARNING: Filesystem still has errors **********

where i cancelled to avoid ruining it.

any idea how to fix the error when mounting as ext3 ?
should i just run fsck.ext3 and tell it to clear journal stuff etc, or would that just remove the ext3 stuff and turn it into ext2 ?
Or is it a bigger mess and i should just use it as ext2 for the time being ?

Help appreciated =)
regards,
g


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]