[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Ext4-beta-list] Problems running bonnie++



Hey all, trying out ext4 in RHEL 5.3:

  # mkfs.ext4 -m 0 -j /dev/Syslog0/lvol0
  # tune4fs -c 0 -i 0 /dev/Syslog0/lvol0
  # tune4fs -E test_fs /dev/Syslog0/lvol0
  # mount -t ext4dev /dev/Syslog0/lvol0
  # cd /mnt
  # bonnie++ -r 8192 -d . -f -u nobody

However, after it runs for a while, I get the following:

  Writing intelligently...done
  Rewriting...done
  Reading intelligently...done
  start 'em...done...done...done...
  Create files in sequential order...done.
  Stat files in sequential order...done.
  Delete files in sequential order...Can't delete file 0011249xQF9yHwY
  Cleaning up test directory after error.

I've made sure the permissions are 777 on the directory and also tried
running the tests as root but still get the same error.

Nothing really odd in the logs or dmesg:

  EXT4 FS on dm-2, internal journal
  EXT4-fs: mounted filesystem with ordered data mode.
  EXT4-fs: file extents enabled
  EXT4-fs: mballoc enabled
  JBD: barrier-based sync failed on dm-2 - disabling barriers

I know now that I should have been using mkfs.ext4dev above instead of
mkfs.ext4 -- but I thought the only difference was that the tune4fs -E
test_fs step wasn't performed for me automatically?

Anyone have any ideas?  Bug perhaps?

Thanks,
Ray


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]