[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 7 kickstart problem with rebuilt Everything image



seth vidal wrote:
On Mon, 2007-07-23 at 11:05 -0600, Phil Meyer wrote:
Howard Wilkinson wrote:
We routinely rebuild systems from a kickstart driven facility we have built. This uses a Fedora image - in this case fedora 7 Everything with the updates merged in. We have run into 2 problems with this as opposed to the original release image.

First the version of yum available in updates currently is incompatible with the version of anaconda. The problem is that this version of yum does not create the headers directory and anaconda assumes it will exist.

    anaconda-11.2.0.66-1.i386.rpm
    yum-3.2.1-1.fc7

To get round this we have reverted to yum-3.2.0-1.fc7.noarch.rpm for now but will probably try out the development releases of anaconda and yum next week.
Confirmed.

A little more detail:

The directory /tmp/cache/headers is created, but empty.
The directory /tmp/cache/anaconda-base-200707231006/headers was not created, and it is here that anaconda is looking for the headers. The first package that it tries to install will throw the error.

Built using pungi-0.3.7-2 with a build system that worked great until the yum update to 3.2.1-1.

Cross posting to fedora-buildsys-list.


3.2.2 has been released - 3.2.2-1.fc7 is in updates-testing. Please test
it.

-sv


--
Fedora-buildsys-list mailing list
Fedora-buildsys-list redhat com
https://www.redhat.com/mailman/listinfo/fedora-buildsys-list

Installed yum 3.2.2 from updates-testing.
Verified that pungi was using and installing the new version.

No difference.

Is there a newer anaconda coming soon?

There seems to be a disconnect here.

First, yum is creating /tmp/cache/headers
Second, anaconda is expecting: /tmp/cache/anaconda-base-200707231006/headers

(where 200707231006 is a date/time stamp)

In either case, the headers directory is empty, and anaconda throws an error if the package header is not found.

Is it yum, or is it anaconda that is asking yum for the wrong thing?

Also, it is not just a kickstart thing. Any pungi derived distro using this stuff cannot be installed manually. A manual install generates the exact same error.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]