[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/kdebindings/devel .cvsignore, 1.30, 1.31 kdebindings.spec, 1.56, 1.57 sources, 1.31, 1.32 kdebindings-3.5.3-gcc-4.1.1-8.patch, 1.1, NONE kdebindings-3.5.3-to-3.5.4.patch, 1.1, NONE



Author: than

Update of /cvs/dist/rpms/kdebindings/devel
In directory cvs.devel.redhat.com:/tmp/cvs-serv30764

Modified Files:
	.cvsignore kdebindings.spec sources 
Removed Files:
	kdebindings-3.5.3-gcc-4.1.1-8.patch 
	kdebindings-3.5.3-to-3.5.4.patch 
Log Message:
rebuild



Index: .cvsignore
===================================================================
RCS file: /cvs/dist/rpms/kdebindings/devel/.cvsignore,v
retrieving revision 1.30
retrieving revision 1.31
diff -u -r1.30 -r1.31
--- .cvsignore	2 Jun 2006 22:41:53 -0000	1.30
+++ .cvsignore	10 Aug 2006 12:23:53 -0000	1.31
@@ -10,3 +10,4 @@
 kdebindings-3.5.0.tar.bz2
 kdebindings-3.5.1.tar.bz2
 kdebindings-3.5.3.tar.bz2
+kdebindings-3.5.4.tar.bz2


Index: kdebindings.spec
===================================================================
RCS file: /cvs/dist/rpms/kdebindings/devel/kdebindings.spec,v
retrieving revision 1.56
retrieving revision 1.57
diff -u -r1.56 -r1.57
--- kdebindings.spec	26 Jul 2006 14:24:21 -0000	1.56
+++ kdebindings.spec	10 Aug 2006 12:23:53 -0000	1.57
@@ -3,16 +3,9 @@
 
 %define appdir %{_datadir}/applications/kde
 
-## stil need fix to build java -> disable java at the moment
-##define support_arch %{ix86} alpha ia64 ppc
-%define support_arch none
-
-%define mozilla_archs %{ix86} ppc s390 s390x x86_64
-
 %{expand: %%define pythonver %(python -c 'import sys;print(sys.version[0:3])')}
-%define mozilla_version 1.7.10
 %define qt_version 3.3.6
-%define arts_version 1.5.3
+%define arts_version 1.5.4
 %define kdelibs_epoch 6
 %define kdebase_epoch 6
 %define perlver 5.8
@@ -26,24 +19,20 @@
 %define pyqt 0
 
 Version: 3.5.4
-Release: 0.pre2%{?dist}
+Release: 1%{?dist}
 Name: kdebindings
 Summary: KDE bindings to non-C++ languages
 URL: http://www.kde.org/
 License: GPL
 Group: User Interface/Desktops
-Prefix: %{_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-
-Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-3.5.3.tar.bz2
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
 
-Patch0: kdebindings-3.5.3-to-3.5.4.patch
 Patch4: kdebindings-3.1-ssl-krb5.patch
 Patch6: kdebindings-3.1-python2.4.patch
 Patch7: kde-libtool.patch
 Patch8: kdebindings-3.3.0-python.patch
 Patch9: kdebindings-3.3.92-xdg.patch
-Patch10: kdebindings-3.5.3-gcc-4.1.1-8.patch
 
 BuildRequires: zlib-devel
 BuildRequires: kdelibs-devel
@@ -53,7 +42,7 @@
 BuildRequires: automake
 BuildRequires: autoconf
 BuildRequires: libtool
-BuildRequires: /usr/bin/desktop-file-install
+BuildRequires: desktop-file-utils
 
 %if %{perl}
 BuildRequires: perl >= %{perlver}
@@ -72,7 +61,8 @@
 Requires: ruby >= %{rubyver}
 %endif
 
-Requires(post,postun): /sbin/ldconfig
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
 Requires: kdelibs >= %{kdelibs_epoch}:%{version}
 Requires: kdebase >= %{kdebase_epoch}:%{version}
 
@@ -91,22 +81,11 @@
 Install %{name}-devel if you want to develop non-KDE
 applications that talk to KDE.
 
-%ifarch %{mozilla_archs}
-%package kmozilla
-Summary: KDE bindings to mozilla
-Group: User Interface/Desktops
-Requires: mozilla
-Requires: kdebase >= %{kdebase_epoch}:%{version}
-
-%description kmozilla
-KDE bindings to mozilla - embed Mozilla in Konqueror
-%endif
-
 %package perl
 Summary: Perl bindings to DCOP
 Group: Development/Libraries
 Requires: kdelibs >= %{kdelibs_epoch}:%{version}
-Requires: perl >= 5.6.0
+Requires: perl >= %{perlver}
 
 %description perl
 Perl bindings to the DCOP interprocess communication protocol used by KDE
@@ -120,60 +99,10 @@
 %description python
 Python bindings to the DCOP interprocess communication protocol used by KDE
 
-%ifarch %{support_arch}
-%package qtjava
-Summary: Java bindings to Qt
-Group: System Environment/Libraries
-Requires: qt >= %{qt_version}
-Requires: libgcj >= 3.1
-Requires: jdkgcj >= 0.2.2
-BuildRequires: gcc-java >= 3.1
-BuildRequires: libgcj >= 3.1
-BuildRequires: jdkgcj >= 0.2.2
-
-%description qtjava
-Java bindings to Qt.
-%endif
-
-%package qtc
-Summary: C bindings to Qt
-Group: System Environment/Libraries
-Requires: qt >= 1:%{qt_version}
-
-%description qtc
-C bindings to Qt.
-Install kdebindings-qtc if you wish to develop Qt applications
-in C (rather than C++).
-
-%package kdec
-Summary: C bindings to KDE
-Group: System Environment/Libraries
-Requires: qt >= 1:%{qt_version}
-Requires: %{name}-qtc >= 3.0.2
-
-%description kdec
-C bindings to KDE.
-Install kdebindings-kdec if you wish to develop Qt applications
-in C (rather than C++).
-
-%ifarch %{support_arch}
-%package kdejava
-Summary: Java bindings to KDE
-Group: Development/Libraries
-Requires: kdelibs >= %{kdelibs_epoch}:%{version}
-Requires: kdebindings-qtjava = %{version}-%{release}
-Requires: libgcj
-
-%description kdejava
-Java bindings to KDE
-%endif
-
 %prep
-%setup -q -n %{name}-3.5.3
-%patch0 -p0 -b .kde3.5.4
+%setup -q
 %patch4 -p1 -b .ssl-krb5
 %patch6 -p1 -b .python2
-%patch7 -p1 -b .libtool
 
 # don't build sip/pyqt, we have separates packages
 %if %{pyqt} == 0
@@ -181,21 +110,10 @@
 rm -rf python
 %endif
 %patch9 -p1 -b .xdg
-#%patch10 -p1 -b .gcc-4.1.1-8
 
 %build
 unset QTDIR && . /etc/profile.d/qt.sh
 
-export CFLAGS="%{optflags}"
-export CXXFLAGS="%{optflags}"
-
-%ifarch %{support_arch}
-export CFLAGS="$CFLAGS `mozilla-config --cflags`"
-export CXXFLAGS="$CXXFLAGS `mozilla-config --cflags`"
-export CPPFLAGS="$CPPFLAGS `mozilla-config --cflags`"
-export LDFLAGS="$LDFLAGS `mozilla-config --libs`"
-%endif
-
 make -f admin/Makefile.common cvs
 
 suffix=""
@@ -221,11 +139,7 @@
    --disable-debug \
    --disable-warnings \
 %endif
-%ifarch %{support_arch}
-   --with-java=%{prefix}
-%else
    --without-java
-%endif
 
 make #%{?_smp_mflags}
 
@@ -245,9 +159,17 @@
 %clean
 rm -rf %{buildroot}
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
+%post
+/sbin/ldconfig
+touch --no-create %{_datadir}/icons/hicolor 2> /dev/null ||:
+gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
+update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
+
+%postun
+/sbin/ldconfig
+touch --no-create %{_datadir}/icons/hicolor 2> /dev/null ||:
+gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
+update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
 
 %files
 %defattr(-,root,root)
@@ -269,10 +191,6 @@
 %{_libdir}/python*
 %endif
 %{_libdir}/perl5
-%ifarch %{support_arch}
-%{_libdir}/java
-%doc %{_docdir}/javalib
-%endif
 
 %files devel
 %defattr(-,root,root)
@@ -280,6 +198,9 @@
 %{_mandir}/man*/*
 
 %changelog
+* Thu Aug 10 2006 Than Ngo <than redhat com> 3.5.4-1
+- rebuild
+
 * Wed Jul 26 2006 Petr Rockai <prockai redhat com> - 3.5.4-0.pre2
 - drop the gcc/g++ workaround, fixed in gcc already
 


Index: sources
===================================================================
RCS file: /cvs/dist/rpms/kdebindings/devel/sources,v
retrieving revision 1.31
retrieving revision 1.32
diff -u -r1.31 -r1.32
--- sources	2 Jun 2006 22:41:53 -0000	1.31
+++ sources	10 Aug 2006 12:23:53 -0000	1.32
@@ -1 +1 @@
-5595b2de6593d1d535ba520abeab4580  kdebindings-3.5.3.tar.bz2
+097eb4311f5715f36fdc83dc5badb476  kdebindings-3.5.4.tar.bz2


--- kdebindings-3.5.3-gcc-4.1.1-8.patch DELETED ---


--- kdebindings-3.5.3-to-3.5.4.patch DELETED ---


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]