[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/bridge-utils/devel bridge-utils.spec, 1.17, 1.18 bridge-utils-1.0.4-kernheaders.patch, 1.1, NONE



Author: dwmw2

Update of /cvs/dist/rpms/bridge-utils/devel
In directory cvs.devel.redhat.com:/tmp/cvs-serv20745

Modified Files:
	bridge-utils.spec 
Removed Files:
	bridge-utils-1.0.4-kernheaders.patch 
Log Message:
drop devel package, use sane kernel headers


Index: bridge-utils.spec
===================================================================
RCS file: /cvs/dist/rpms/bridge-utils/devel/bridge-utils.spec,v
retrieving revision 1.17
retrieving revision 1.18
diff -u -r1.17 -r1.18
--- bridge-utils.spec	11 Feb 2006 02:12:14 -0000	1.17
+++ bridge-utils.spec	7 Jun 2006 22:07:01 -0000	1.18
@@ -1,15 +1,15 @@
 Summary: Utilities for configuring the linux ethernet bridge
 Name: bridge-utils
 Version: 1.0.6
-Release: 1.2
+Release: 2
 License: GPL
 URL: http://bridge.sourceforge.net/
 Group: System Environment/Base
 Source: http://dl.sf.net/bridge/bridge-utils-%{version}.tar.gz
 Patch0: bridge-utils-1.0.4-inc.patch
-Patch1: bridge-utils-1.0.4-kernheaders.patch
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: sysfsutils-devel
+BuildRequires: kernel-headers >= 2.6.16
 
 %description
 This package contains utilities for configuring the linux ethernet
@@ -20,33 +20,17 @@
 
 Install bridge-utils if you want to use the linux ethernet bridge.
 
-%package devel
-Summary: Utilities for configuring the linux ethernet bridge
-Group: Development/Libraries
-
-%description devel
-The bridge-utils-devel package contains the header and object files
-necessary for developing programs which use 'libbridge.a', the
-interface to the linux kernel ethernet bridge. If you are developing
-programs which need to configure the linux ethernet bridge, your
-system needs to have these standard header and object files available
-in order to create the executables.
-
-Install bridge-utils-devel if you are going to develop programs which
-will use the linux ethernet bridge interface library.
-
 %prep
 %setup
 
 %patch0 -p1
-%patch1 -p1
 
 %build
-%configure --with-linux-headers=`pwd`
+%configure
 make
 
 %install
-make DESTDIR=${RPM_BUILD_ROOT} install
+make DESTDIR=${RPM_BUILD_ROOT} SUBDIRS="brctl doc" install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -57,12 +41,10 @@
 %{_sbindir}/brctl
 %{_mandir}/man8/brctl.8*
 
-%files devel
-%defattr (-,root,root,0755)
-%{_includedir}/libbridge.h
-%{_libdir}/libbridge.a
-
 %changelog
+* Wed Jun 07 2006 David Woodhouse <dwmw2 redhat com> 1.0.6-2
+- Use sane kernel headers, drop -devel package
+
 * Fri Feb 10 2006 Jesse Keating <jkeating redhat com> - 1.0.6-1.2
 - bump again for double-long bug on ppc(64)
 


--- bridge-utils-1.0.4-kernheaders.patch DELETED ---


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]