[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Proposal: Install swfdec by default.



Brian Pepple <bpepple <at> fedoraproject.org> writes:

> I would like to propose that we [possibly] install ... swfdec-mozilla
> by default starting with F9.
> 
As the maintainer of Swfdec, I'd like to add some comments about this option
that should help you decide about this proposal.

The short version is that I would not recommend Swfdec for distro releases that
do a long-term support release. Apart from that, I'd be very happy if
distributions include Swfdec as long as they don't expect a perfect Flash 
player.

Swfdec has arrived at a stage where it can be useful to a lot of people. It
plays most smaller Flash files and is often good enough for mid-sized Flash
files, such as the players on the various video sites or Flash games. However
it's also pretty bad on Flash-heavy websites and not very good at playing 
Flash 9.

However, there's also some reasons that speak against Swfdec. Swfdec has not 
had a lot of exposure yet. I have no clue about how many people use it, but 
shipping it by default on a distro such as Fedora would increase that a lot. 
And exposure can uncover lots of issues that upstream (we) didn't think about, 
such as finding lots of problematic crasher bugs or flooding our bugzilla. I've
experienced this exposure issue once with GStreamer, so I feel pretty well
prepared, but who knows.

Another issue coupled with the above is that the Swfdec plugin runs in-process
in the browser. [1] This of course means that when Swfdec crashes, your browser
is gone, too. However, we're still proud of the Swfdec's stability. But you 
have been warned. :)
Another thing is that Swfdec has never been security audited. We've run it with
tools like zzuf, we've got pretty evil tests in our testsuite, we copy an
existing and proven system, but we're no security experts and Swfdec is 50k
lines of code.

Swfdec is also in heavy development, I tend to call it "surprisingly usable
alpha software". We change a lot of code quickly. (A year ago Swfdec didn't 
even play Youtube.) This also means that we currently don't want to support the
current versions eternally. (Probably - like Gnome - we'll actively support it
until the next stable version is released in 6 months.) This is my main reason
for not suggesting it for long-term support releases.

So that being said, I'd be very happy to see you install Swfdec-Mozilla by
default. I'm running it in my default browser since about a year and I didn't
get annoyed at it.

Cheers,
Benjamin


[1]: https://bugs.freedesktop.org/show_bug.cgi?id=9805


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]