[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: perl-devel will be removed from the f8 buildroots



Robin Norwood <rnorwood redhat com> writes:

> Hi,
>
> On Monday, perl-devel will be removed from the f8 buildroots.  This
> means that if you try to build a perl-* package that uses the perl build
> tools, you will need to add those tools to the BuildRequires for the
> package.  The most common will be:
>
> BuildRequires: perl(ExtUtils::MakeMaker)
>
> But you should also watch the build output to make sure tests aren't
> being skipped due to other missing modules.

FESCo voted on this issue today and passed the following proposal:

Remove perl-devel from default buildroot.  Assist others with proper
spec fixups.  Alert time of removal is 1 week.

So, what we'll be doing is:

o Various people have volunteered to help convert packages to use the
specific Buildrequires tags.  If anyone wants to ask for assistance with
their packages, do so here, and we'll take care of them for you.

o There will soon be a 'perl-core' metapackage, that will Require
everything that has been split from the main 'perl' package -
essentially everything in the upstream tarball, except for suidperl.  It
is stronly encouraged that package maintainers BuildRequire the specific
perl modules their package needs to build instead of this package.

o Next Thursday (the 12th of July), the buildroots will be changed to
remove the 'devel' bits

This means that any packages that haven't been fixed yet will not
build.  But of course we can easily fix them on a one-off basis.

-RN

-- 
Robin Norwood
Red Hat, Inc.

"The Sage does nothing, yet nothing remains undone."
-Lao Tzu, Te Tao Ching


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]