[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[fedora-java] Did the Eclipse update in updates-testing break for anyone else?



Yesterday, I updated to the eclipse* packages that are currently in
updates-testing. Before that, Eclipse started up cleanly; now, I get
an error on start-up to look in a logfile under
~/.eclipse/org.eclipse.platform_3.2.0/configuration. That starts with:

!ENTRY org.eclipse.core.runtime 4 0 2006-11-19 18:56:20.352
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs;
bundle-version="[3.2.0,4.0.0)"
[backtrace]


!ENTRY org.eclipse.osgi 4 0 2006-11-19 18:56:20.358
!MESSAGE Bundle
initial reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/
was not resolved.

[...]

I tried going back to the versions from core, but I'm still getting
that error. It is correlated with the update, so I definitely suspect
that in some way, but I didn't want to bugzilla it (it may be
something in my local config) without checking.

I hope I don't have to rebuild my workspace again ... argh. :(

MEF

--
Mary Ellen Foster
http://homepages.inf.ed.ac.uk/mef/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]