[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-java] libvirt-java bindings



2008/7/1 David Walluck <david zarb org>:
> Unfortunately, there are recent packages passing the Fedora review that
> directly specify java-1.6.0-openjdk-devel as the JDK and I personally
> don't like this.

I have one recent package that does this (specifies openjdk on F9+ and
icedtea on F8) and one that doesn't (just wants java >= 1.5). The
first package uses JNI and needs a Sun-like JVM to work (or at least
it took more autotools hacking than I cared to try to make it work),
and if I just put Requires: java it tended to grab gcj. I guess I
could also put java > 1.5, but the issue isn't the 1.5-ness, it's the
Sun-style JNI classes.

(The packages are pl-jpl and ice-java, respectively, if you're wondering).

MEF

-- 
Mary Ellen Foster -- http://homepages.inf.ed.ac.uk/mef/
Informatik 6: Robotics and Embedded Systems, Technische Universit√§t M√ľnchen
and ICCS, School of Informatics, University of Edinburgh


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]