[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

feedback and request for help with x86_64 preview



First of all, thanks very much to everyone who's working hard to get FC1
working on x86_64 - your efforts are much appreciated.

I've been trying to install the fc1_x86_64 preview on my AMD Athlon 64
3200+ box, with MSI-6702 (a.k.a K8T Neo) m/b, which uses a VIA K8T800
chipset + VIA VT8237, and also has a Promise 20378 SATA controller.
(c.f.
http://www.msicomputer.com/product/detail_spec/product_detail.asp?model=K8T_Neo-FIS2R
). For the record I have 512MB DDR RAM and the graphics card is ATI
9600. I have one SATA disk attached to the VT8237 controller which has a
single partition containing Windows XP Home. Leaving aside the fact that
this seems to be a bad combination of hardware in terms of linux
support, here is my story:

I downloaded the http://fedora.linux.duke.edu/fc1_x86_64 tree to another
machine on my home network and burnt the boot.iso to a CD.
I tried a "linux rescue" installation so I could get a shell and use
parted to resize the existing partition and add ext3/swap partitions for
linux.
I had no problem choosing HTTP installation and configuring network
settings (except for Bug #112683), but after retrieving stage2.img
anaconda says I have no hard disks and drops me to a shell, so it seems
my VIA SATA controller is not being found/recognised for some reason.
>From the shell prompt I couldn't get parted to find the SATA disk -
possibly because I was using the wrong device name, possibly because the
controller's not being found.
I downloaded the fedora/core/development/x86_64 (nee rawhide) tree
instead and tried installing that, but got lots of error messages about
slab corruption on the console and so abandoned the development version
and rebooted.
I installed an old 3.2GB IDE disk I had lying around, to try and install
fc1_x86_64 onto that (in order to compile a working via_sata.o and then
move the system to the SATA disk) which worked to a point, but when
anaconda was about to partition the IDE disk it managed to completely
destroy the disk so that even the BIOS can't see it (the disk was old
and I suspect it was about to fail anyway - this is unlikely to be
anything to do with FC1). This left me back where I started, with
anaconda not finding my SATA disk.

At this point I'm about to borrow another old IDE disk, am downloading
the http://fedora.linux.duke.edu/fc1_x86_64/jmforbes/ tree (which looks
like the latest one, is that right?) to try to install tonight, and will
also ensure my BIOS is up to date (possibly not).

So, my first question is has anyone successfully installed fc1_x86_64 on
an MSI mobo?
The list archives seem to indicate it's been tried on ASUS, Tyan and
others, but no explicit mention of MSI or K8T Neo.

Why didn't the VIA SATA controller get found?
I was under the impression (thanks to
http://www.redhat.com/archives/fedora-devel-list/2003-November/msg01216.html
 and other posts) that the fc1_x86_64 preview included support for VIA
and promise SATA controllers.
(Note that the disk might be found if my BIOS is out-of-date and I flash
it tonight, the latest version contains fixes for both the VIA and
Promise controllers)

Should I be trying the /fc1_x86_64/jmforbes/ tree? What about the
/fc1_x86_64/preview/ tree?

What is the correct device name for the first SATA disk likely to be,
/dev/sda? It's possible I just failed to call parted with the right
name! Should anaconda have found the existing windows partition, even
though it's on a SATA disk? (I thought the answer to this was yes, and
if anaconda can't find it then neither will parted, is that right?)

Sorry this feedback is a little incomplete, but I can't remember exactly
what I've tried so far (e.g. can't remember what device names i did and
didn't try with parted) and wanted to send this before I try a third set
of installation images. I'd be very grateful for any help or advice, or
even flames if anything I've done stands out as particularly stupid
(except not flashing the BIOS earlier - I know that's stupid :-)

jon


http://www.mintel.com

London Office:
Mintel International Group Ltd (Mintel)
18-19 Long Lane
London
EC1A 9PL
UK

Tel: 020 7606 4533
Fax: 020 7606 5932

Chicago Office:
Mintel International Group Ltd (Mintel)
213 West Institute Place
Suite #208
Chicago
IL 60610
USA

Tel: 312 932 0400
Fax: 312 932 0469

Notice
********
This email may contain information that is privileged,
confidential or otherwise protected from disclosure. It
must not be used by, or its contents copied or disclosed
to, persons other than the addressee. If you have received
this email in error please notify the sender immediately
and delete the email. Any views or opinions expressed in
this message are solely those of the author, and do not
necessarily reflect those of Mintel.

No Mintel staff are authorised to make purchases using
email or over the internet, and any contracts so performed
are invalid.

Warning
**********
It is the responsibility of the recipient to ensure that
the onward transmission, opening or use of this message
and any attachments will not adversely affect their systems
or data. Please carry out such virus and other checks, as
you consider appropriate.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]