[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM segfaulting



On Sunday 19 October 2003 15:23, Barry K. Nathan wrote:
> On Sun, Oct 19, 2003 at 11:25:38AM -0400, Gene C. wrote:
> > I agree ... but he would likely be interested in the copy BEFORE I ran
> > --rebuilddb ... which I do not have.
> >
> > Since more than one person has had this problem, hopefully the next
> > person to get the problem will save a copy before doing --rebuilddb.
>
> I have a few questions for anyone experiencing this:
>
> (a) Are these systems, experiencing this problem, fresh installs of
> Fedora Core 0.95 (or upgraded from Fedora Core 0.94) -- or were they
> upgraded from Red Hat 9.0.93 or earlier? If the latter, what release was
> it upgraded from?
>
> (b) Does the system have an i586 CPU (Pentium, Pentium MMX, AMD K6, and
> some others I don't remember right now)?
>
> (c) If the answer to (b) is "no", are you running the kernel shipped
> with Fedora Core (or a 2.6 kernel), or are you running something else
> (like a Red Hat 9 kernel or a mainline kernel)?


OK, I had the problem with a fresh everything install of FC 0.95 (deleted some 
language packages to get some space) and then also applied a couple of days 
worth of rawhide updates.  The problem "went away" after I did the 
--rebuilddb (unfortunately, I did not capature before/after info).  I tried 
to recreate the problem with an "almost everything" install (select 
everything I could but not a true "everything" install) and then (again) 
applied the updates then available from rawhide ... this time, there was no 
segfault problem.

As Jeff Johnson pointed out to me, this is some kind of data problem in the 
rpm db.  At this point, I am moving on because I do not believe that I can 
truely recreate the problem (I am sure it is still there and will pop up 
again for someone in the future but I cannot help define the problem now).  
Some sequence of install/remove elft the db is bad shape ... what that is is 
currently unknown.

The hardware is a 800MHz PIII and runs the Fedora kernel.
-- 
Gene




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]