[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

USB storage detected, but not accessible? Please help!

I am having trouble accessing my FujiFilm FinePix 3800 camera in Raw Hide (it worked perfectly in FC1 and earlier).

When I connect it and turn it on, logs get:

usb 1-1: new full speed USB device using address 8
SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
USB Mass Storage device found at 8
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.

and the usb_storage and scsi_mod modules get loaded. However, the camera does not seem to get "attached" to any specific /dev/xyz (or /udev/xyz for that matter) - e.g. when I try to access /dev/sda, I get "No such device or address".

% cat /proc/scsi/scsi
Attached devices:

% cat /proc/scsi/usb-storage/0
   Host scsi0: usb-storage
       Vendor: Unknown
      Product: USB Mass Storage
Serial Number: Y-406^^^^^030528XFPX0007040092
     Protocol: 8070i
    Transport: Control/Bulk/Interrupt

% cat /proc/bus/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.5-1.319custom uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1d.0
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  8 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04cb ProdID=011a Rev=10.00
S:  Product=USB Mass Storage
S:  SerialNumber=Y-406^^^^^030528XFPX0007040092
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=08(stor.) Sub=05 Prot=00 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=1ms

I tried both 2.6.5-1.322 and 2.6.5-1.319custom (kernel-source recompiled using stock config-i686 with 4G and 4G+4G disabled, APM disabled, SOFTWARE_SUSPEND enabled).

Am I doing something wrong? Or is this a bug (and should be reported)? Is there some way to make it work? Thanks a lot for any help.

P.S. Other USB devices (printer, mouse) work OK.

Aleksey Nogin

Home Page: http://nogin.org/
E-Mail: nogin cs caltech edu (office), aleksey nogin org (personal)
Office: Jorgensen 70, tel: (626) 395-2907

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]