[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Who is to write /etc/modprobe.conf?

On Wed, 21 Apr 2004 01:19:29 -0400
Bill Nottingham <notting redhat com> wrote:

> Pete Zaitcev (zaitcev redhat com) said: 

> > On FC2T2, I ran system-soundcard-config, and it did not play a test sound.
> > It turned out that it runs kudzu, and once kudzu is done, it expects that
> > necessary modules would autoload, which was not the case, because the
> > /etc/modprobe.conf did not have the necessary entries:
> > 
> > alias snd-card-0 snd-emu10k1
> > alias sound-slot-0 snd-card-0
> Won't work. You can't have an alias to an alias with the new module
> tools.

My bad. The sound-slot-0 alias is entirely unnecessary.

> This is cleaned up some in current rawhide modutils/kudzu/s-c-soundcard.

Woops, my bad again. I updated to the rawhide (see below for versions),
killed soundcard from /etc/sysconfig/hwconf, reran kudzu and everything
works now.

[zaitcev pentabug zaitcev]$ rpm -q kudzu modutils system-config-soundcard
[zaitcev pentabug zaitcev]$ cat /etc/modprobe.conf
include /etc/modprobe.conf.dist
alias eth0 3c59x
alias usb-controller uhci-hcd
alias usb-controller1 ohci-hcd
alias usb-controller2 ehci-hcd
alias snd-card-0 snd-emu10k1
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1
[zaitcev pentabug zaitcev]$

OK, so with the ALSA out of the way I can turn back to USB.

Actually, one more question. The system-config-soundcard depends on sox,
because it uses play(1). Would it be worth the trouble to redo it to use
aplay(1) and depend on alsa-utils instead?

-- Pete

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]