[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anaconda secure by default :-)

On Wed, 2004-04-28 at 15:57, Ricardo Gorosito wrote:

I installed everything with a firewall. Anaconda stack
looks similar:
Traceback (most recent call last):

File "/usr/lib/anaconda/gui.py", line 1044, in handleRenderCallback

File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback

File "/usr/lib/anacconda/gui.py, line 763, in nextClicked

File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
  rc = apply(func, self.bindArgs(args))

File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext

File "usr/lib/anaconda/packages.py, line 1111, in doPostInstall
  devnull = os.open("/dev/null", os.O_RDWR)

OSError: [Erro 1] Operation not permitted: '/dev/null'

My system is a dual processor x64_64. Anaconda is installing
Wordtrans-web01.1pre13.4.x76_64 (85 KB)
Web front-end for wordtrans.

I'm wondering if I should select "Debug" or "OK" and if
I should file a Bugzilla bug on it.


> When I tried to disable firewall on install, Anaconda die with:
> ---start paste---
> Traceback (most recent call last):
>   File "/usr/lib/anaconda/gui.py", line 759, in nextClicked
>     rc = self.currentWindow.getNext ()
>   File "/usr/lib/anaconda/iw/firewall_gui.py", line 32, in getNext
>     self.security.setSELinux(self.se_option_menu.get_history())
>   File "/usr/lib/anaconda/security.py", line 39, in setSELinux
>     raise ValueError, "Setting to invalid SELinux state: %s" %(val,)
> ValueError: Setting to invalid SELinux state: -1
> Local variables in innermost frame:
> self: <security.Security instance at 0xb7d8c0cc>
> val: -1
> ---end error---
> Solved installing with FW enabled
> Ricardo.-
> -- 
> fedora-devel-list mailing list
> fedora-devel-list redhat com
> http://www.redhat.com/mailman/listinfo/fedora-devel-list
piet www piet net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]