[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ethereal update package broken



On Thu, 15 Jul 2004 11:53:39 -0400, Matthew Miller wrote:

> Hmmm. When I rebuild the ethereal-0.10.5-0.2.1.src.rpm, the resulting
> packages won't install, complaining about a missing dependency
> 'libethereal.so.0'. 
> 
> A bit more investigation reveals this interesting difference:
> 
> Original FC2 package:
> 
> $ rpm -qlp ethereal-0.10.3-2.i386.rpm |grep libethereal
> /usr/lib/libethereal.so
> /usr/lib/libethereal.so.0
> /usr/lib/libethereal.so.0.0.1
> 
> Update package:
> 
> $ rpm -qlp ethereal-0.10.5-0.2.1.i386.rpm |grep libethereal
> /usr/lib/libethereal
> /usr/lib/libethereal.0
> /usr/lib/libethereal.0.0.1
> 
> Hey! What happened to the .so? This is the case with both my rebuilt package
> and the distributed update binary.

That's due to an autotools/libtool mismatch.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]