[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: AMD64 package help needed



On Tue, 20 Jul 2004 21:50:01 -0400, Sam Varshavchik wrote:

> Michael Schwendt writes:
> 
> > On Tue, 20 Jul 2004 20:19:17 -0400, Chuck Mead wrote:
> > 
> >> |>|   https://bugzilla.fedora.us/show_bug.cgi?id=1421
> > 
> >> | With the current procedure it is expected to build on FC1 to FC3.
> >> 
> >> Well... it requires a package which does not appear to be available for
> >> FC2 on x86_64.
> >> 
> >> error: Failed build dependencies:
> >> ~        libsigc++-devel >= 0:1.2.0 is needed by gtkmm20-2.2.12-0.fdr.1.2
> > 
> > libsigc++ was fixed for x86_64 a few days ago:
> > 
> >   http://www.fedora.us/pipermail/fedora-package-announce/2004-July/000605.html
> > 
> > I don't know who maintains the x86_64 extras tree...
> 
> I cannot reach www.fedora.us at the moment, but I assume that the above fix 
> was to simply rebuild libtool and configure, because that's all I had to do 
> to fix libsigc++ for x86_64:

Which is what I did for libsigc++, too, albeit I also recreated automake's
files.

But above packages are _version upgrades_ from upstream project. What I'd
like to know is whether they _still_ need the fix, too, as a fix ought to
be shipped upstream and included there. Running auto*/libtool in spec
files creates dependencies on those tools. This can get unclean when you
want to build the same src.rpm for multiple distributions or as soon as
upstream moves to a different (maybe less/not compatible) version of the
tools.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]