[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

gnupg newpg gpgme gpgme03 cryptplug isuses

Recently the version of libgcrypt was increased  to 1.1.94  as a result of 
this newpg would not build against the newer libgcrypt  i sent an email to 
gcrypt-devel list and this is what i got back 

Don't build newpg at all.  It has been superseded by gnupg-1.9.x .

You would need an old libgcrypt < 1.1.42 to build it.  The configure
sscript was not able to detect newer versions with a changed API. 

we have a problem here seems we no longer need newpg  but we need things it 
provides  for gpgme gpgme03 cryptplug  gpa  kgpg (which doesnt complain so 
much  just says its not there)   to get these things it provides  we need to 
go to the newer gnupg  or we need to revert back to the older libgcrypt.

being so late in the cycle i dont know which would be best.  so i thought id 
ask before filling a bug against something.  it does need to be fixed before 
final is out  as people will complain if they cant decrypt email in kmail or 
mutt gpa doesnt work  etc. i think we should probably go back to the old 
version of libgcrypt


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]