[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: python2.2 -> python2.3



On Wed, 13 Oct 2004 02:46:26 -1000, Warren Togami wrote:

> Michael Schwendt wrote:
> > 
> > If you buildrequire Mozilla or Qt, you can query them without problems,
> > of course. Because when they're not installed in the build environment,
> > rpmbuild fails. And when they're installed, querying them works.
> > 
> 
> You can query mozilla or qt during %prep %build or %install, but not 
> during preprocessing.

Why not?
 
I refer to rare cases like this (.spec file excerpt):

Buildrequires: kdelibs-devel
%if %{!?_with_kde32:1}%{?_with_kde32:0}
  %define have_mimetypedefs 1
%else
  %define have_mimetypedefs %(if test -z $(rpm -ql kdelibs | grep -m1 x-iso.desk
top); then echo 0; else echo 1; fi)
%endif


This is no different from running Python or Perl code. If, however, you
mean "it is now permitted to do that although it works with plain
rpmbuild" (but breaks cross-platform build tools like mach), then that's
a different side of the story.

-- 
Fedora Core release 2.92 (FC3 Test 3) - Linux 2.6.8-1.541
loadavg: 1.35 1.22 0.83


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]