[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora and xine.



Pritesh Shah wrote:

I'm trying to install xine in my system. i downloaded the binaries
from freshrpms for fedora 2. i got i think all the prerequisite
packages needed installed. when i'm trying to install xine it reports
the following error:

# rpm -ivh xine-0.99.2-1.1.fc2.fr.i386.rpm
warning: xine-0.99.2-1.1.fc2.fr.i386.rpm: V3 DSA signature: NOKEY, key
ID e42d547b
error: Failed dependencies:
libcurl.so.2 is needed by xine-0.99.2-1.1.fc2.fr


The first problem is that curl is very poorly packaged. Libraries should be packages such that they are parallel installable. I have already filed a bug against the curl package for this.

For the fix, I just made a symlink from libcurl.so.2 to libcurl.so.3. They seem to be compatible enough for Xine to at least run. It might reduce stability, though I haven't seen any problems. I don't run Xine over the network, however.

Finally, this list is about developing Fedora, not user questions - use fedora-test-list for that.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]