[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Filesystem "binary compatibility" question



Jerone Young wrote :

> A file systems structures do not change accross architetures. So a PPC
> or X86_64 enviroment reads it the same way an i386 enviroment (if they
> programmed it right,and as far as I know xfs is).  Now bootable
> partions accross different aritectures is another story :-)

I have no problems accessing from an x86 the ext3 partitions made from the
x86_64 host that are on the same physical disk as that problematic xfs one.
It's not the first time I try, with this exact same disk... last time I
gave up trying to read it from an x86 host, and when I tried looking into
the problem my x86_64 machine was having... gone, it was booting again, so
I just put the disk back in, and it worked fine.

Now, that x86_64 doesn't boot anymore (same problem), and I tried (again)
to access the disk's data from an x86 test machine, and I can mount the
ext3 partitions fine, I can even get the disk's grub to appear and the
kernels tell me that I need a 64bit system for them to work ;-) But trying
to mount that xfs partition (made on the x86_64 host running FC2) gives me
a segfault every time, which is why I was asking : I'm 100% sure my x86_64
FC2 host could still read that partition if it still booted, whereas no x86
FC2 or FCDev can, as I see it...

I've tried searching for info regarding possible incompatibilities for
filesystems between archs, but can't seem to find anything relevant to my
problem.

> If your signature is correct your running FC3 test 2 (and upgraded the
> hell out of it), do a clean install and try RC2.

That's my laptop, a completely different matter :-)

Matthias

-- 
Clean custom Red Hat Linux rpm packages : http://freshrpms.net/
Fedora Core release 2.91 (FC3 Test 2) - Linux kernel 2.6.9-1.643.radeon
Load : 0.26 0.29 0.31


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]