[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 and Yum Plugins



On Sat, Dec 31, 2005 at 02:09:50PM -0500, Tom Diehl wrote:
> Axel Thimm <Axel Thimm ATrpms net> wrote:
> 
> > On Sat, Dec 31, 2005 at 05:17:02PM +0000, David Woodhouse wrote:
> >> On Sat, 2005-12-31 at 11:49 -0500, Jeff Spaleta wrote:
> >> Er, or just volunteer to package mythtv for livna?
> >
> >That is the second time this suggestion comes up in this thread. What
> >makes livna and ATrpms different, or say livna preferable to ATrpms in
> >this context? At the beginning of this thread some people posted about
> >livna replacing packages just as well.
> 
> The fact that Livna would not pull in a bunch of rpms that, for instance myth TV
> does not need. The last time I tried to install a myth box from ATrpms
> it wanted to replace yum. NO, I do not want the ATrpm version of yum installed.
> Myth does not need it.

Oh yes, it did:

https://www.redhat.com/archives/fedora-list/2005-January/msg01826.html

Maybe it doesn't anymore, but for good manners everytime a yum release
comes up and mentiones bugs fixed I run and distribute it to ATrpms
folks and they are *happy* about it. Especially the ones running FC
older then the latest, that doesn't get any yum problems fixed
anymore.

> I only want the packages NECESSARY for myth to work installed. IIRC,
> I thought I could bump my version of yum to override it but upon
> inspection there was some specific tag that required the use of the
> ATrpms version.

No, that's wrong. yum/smart/apt at ATrpms are deliberately kept atrpms
agnostic, so they can be used in any other context. You can even use
them w/o using ATrpms at all.

> I use a custom version of yum that I build so that I can serve up the yum.conf
> files from a web server. Why would I want to replace my version of yum with
> ATrpms? If ATrpm's deps were sane this would not be a problem but the last time
> I looked they are not.

The problme is that you want a piece of the cake and not all of
it. You could just as well not like firefox version so and so shipped
with Fedora Core. Using Fedora Core means that there is an ensemble of
packages that you pull from. Using a third party repository is no
different.

Noone needs all of ATrpms. Noone needs all of Fedora Core either. But
it is not easy to create a subrepo for every taste. Some like it
mythtv, others like cluster software, others security scan tools. If a
3rd party repo were to fine grain its contents it would probably end
up with a suprepo per package. I once was trying to keep packages in
"topics", but soon failed to properly continue it due to the overhead
induced:

		http://atrpms.net/topic/

It really gets a nightmare to serve sub-repos.

> >Just for the note: Fedora itself, when it wasn't merged with RHL (aka
> >fedora.us) decided to have vendor packages replaced. packages like
> >shadow-utils or rpm itself.
> 
> IIRC only on a VERY limited basis. If you are referring to the rpm upgrade 
> for RHL 8.0, as far as I am concerned NOT upgrading was a mistake on Red Hat's
> part. That upgrade made the system usable and the decision to do that was
> very controversial.

I don't want to go into detail, I myself applaude this decision, I
just want to demostrate that this was once a policy of Fedora and then
suddenly became a sin for 3rd party repos. Doesn't that make you feel
like a second class citizen?

> Disclaimer: I have not actually looked at this in approx 6 months. If things
> have changed then that is good and I would appreciate being corrected. I really
> do appreciate the work 3rd party repos do. I used to use Dag's repo quite
> frequently and I would gladly use ATrpms if the deps were not so intrusive.

That explains the above statements. W/o wanting to push you, you are
making claims that aren't true neither now nor back then, because you
either forgot the details or only checked superficially the problems
you were facing. So you're actually adding to the problem of FUD.
-- 
Axel.Thimm at ATrpms.net

Attachment: pgpzRxqPGnmIJ.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]