[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 3 kernel 2.6.10-1.770_FC3 and nfsroot problem for PXE/diskless (CONFIG_ROOT_NFS=y)



hi all,
im trying to setup a diskless environnement with Fedora.
I use etherboot (as a bootable CDROM) to load linux kernel via PXE.
I have a dhcp, nfs and a tftp server working properly.
I have rebuild a 2.6.10-1.770_FC3 fedora kernel because latest 2.6.11
kernel series can't be build on my FC3.
I have rebuild a kernel (as an rpm, or via make bzImage), with the
NFSROOT option, to allow / mounting via NFS
pxelinux.0 boot normaly, load the kernel and the initrd, but when the
kernel try to moun the / partition, i obtain a kernel panic message:

VFS: Cannont open root device "nfs" or unknow-block(0,255)
Please append a correct "root=" boot option
Kernel Panic - not syncing : VFS: Unable to mount root fs on
unknow-block(0,255)

After that, i have tried many other options in the linux kernel (using
devfs instead udev, yes i know it's obsolete :)), and some other tips i
found but no one worked. Note that on the NFS Server i don't see any
packet using the NFS protocol.
Is there some special configuration with Fedora kernels and nfsroot option ?

Thanks for your suggest


¤ Here is my pxelinux.cfg/default file : kernel FC3_PXE/vmlinuz APPEND ramdisk_size=100000 root=/dev/ram0 nfsroot=192.168.1.14:/DOC/PXE/root or APPEND initrd=FC3_PXE/initrd.img ramdisk_size=10000 root=/dev/nfs nfsroot=192.168.1.14:/DOC/PXE/root


¤ Here is the main kernel option needed (if i don't miss one!) and that i have in my kernel: grep -i "IP_PNP\|NFS\|RAMFS" /DOC/PXE/root/boot/config-2.6.10-1.770_FC3nscheibl.20050525 CONFIG_INITRAMFS_SOURCE="" CONFIG_IP_PNP=y CONFIG_IP_PNP_DHCP=y CONFIG_IP_PNP_BOOTP=y CONFIG_IP_PNP_RARP=y CONFIG_RAMFS=y CONFIG_CRAMFS=m CONFIG_NFS_FS=y CONFIG_NFS_V3=y CONFIG_NFS_V4=y CONFIG_NFS_DIRECTIO=y CONFIG_NFSD=m CONFIG_NFSD_V3=y CONFIG_NFSD_V4=y CONFIG_NFSD_TCP=y CONFIG_ROOT_NFS=y CONFIG_NCPFS_NFS_NS=y

¤ Here is the config of the diskless client in my dhcp server
(/etc/dhcpd.conf):
group {
           next-server 192.168.1.14;
           filename "linux-install/pxelinux.0";
           option root-path "192.168.1.14:/DOC/PXE/root,v3,tcp,hard";
        host PXED {
           hardware ethernet 00:48:54:XX:YY:ZZ ;
           fixed-address 192.168.1.133;
           }
       }

¤ And here is my nfsd config (/etc/exports):
/DOC/PXE/root *(ro,no_root_squash,sync)
/DOC/PXE/snapshot *(rw,no_root_squash,sync)







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]