[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide->fc5; X won't start



Kevin Fenzi wrote:
"sean" == sean  <seandarcy2 gmail com> writes:

sean> I installed xfce to see if it was a gnome/kde problem. Here's
sean> what shows on the xfce console:

(==) Using config file: "/etc/X11/xorg.conf" /usr/bin/startxfce4: X
server already running on display :0 Agent pid 4100 which: no
xfce4-session in
(/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/NX/bin:/root/bin)
(xfce-mcs-manager:4103): libxfce4mcs-CRITICAL **:
mcs_manager_add_channel_from_file: assertion `filename != NULL &&
strlen (filename) > 0' failed /etc/xdg/xfce4/xinitrc: line 106:
4105 Segmentation fault xfwm4 --daemon ** Message: Cannot connect
to session manager /etc/xdg/xfce4/xinitrc: line 123: 4108
Segmentation fault xfcalendar /etc/xdg/xfce4/xinitrc: line 123:
4110 Segmentation fault $panel

sean> So X appears to start - Fedora logo comes up; no error on
sean> Xorg.0.log.

sean> But no gui's will start - not gnome,kde or xfce. Does this mean
sean> X isn't starting correctly so that the gui's can start? If not,
sean> what happens between X coming up and the gui's starting?

sean> metacity?  Is there any way to cause metacity to do verbose
sean> logging?

sean> Again, is there any way to get more verbose and clearer logs.

sean> Or any other hints?

Well, not sure on gnome or KDE, but the above Xfce output looks like
the problem is the Seg faults when trying to start up. :( Several other things to try:
- If you create a new fresh user, can they login ok?
(This would point to it being you users gtk theme, fonts setup or the
like).

Yes! I can login as a new user. Switched xorg.conf back to using xfs, and that worked to.

( Oddly, when I logout as the new user, I'm left at console 7 with a black screen and a blinking cursor at top left. console 1, witch I have to manually switch to, shows the usual X shutdown stuff.)

- Could be some package leftover from your rawhide install causing
issues, perhaps a 'yum list extras' to identify any packages that are
not in repositories you have currently enabled?

- Could you try and run xfwm4 under a debugger?
0) yum --enable-repo=core-debuginfo install xfwm4-debuginfo
yum --enablerepo=extras-debuginfo ........  :)

1) Run X from a console, "xinit /usr/X11R6/bin/xterm &"
2) Switch to a console (Ctrl+Alt+F1)
3) Set the display "export DISPLAY=:0.0"
4) run "gdb /usr/bin/xfwm4"
5) if/when it crashes, run 'bt' and send me the backtrace.

Well, it appears to be font related. I hope you can figure out what the font problems is though. Here's the backtrace:

gdb /usr/bin/xfwm4
GNU gdb Red Hat Linux (6.3.0.0-1.122rh)
...................
(gdb) run
Starting program: /usr/bin/xfwm4

Program received signal SIGSEGV, Segmentation fault.
0x0000003fa28233ff in FcPatternUnserialize () from /usr/lib64/libfontconfig.so.1
(gdb)
(gdb) bt
#0 0x0000003fa28233ff in FcPatternUnserialize () from /usr/lib64/libfontconfig.so.1 #1 0x0000003fa282344e in FcPatternFindElt () from /usr/lib64/libfontconfig.so.1
#2  0x0000003fa2824b76 in FcPatternGet () from /usr/lib64/libfontconfig.so.1
#3 0x0000003fa2824e73 in FcPatternGetString () from /usr/lib64/libfontconfig.so.1 #4 0x0000003fa28136d1 in FcConfigBuildFonts () from /usr/lib64/libfontconfig.so.1 #5 0x0000003fa281b8bb in FcInitLoadConfigAndFonts () from /usr/lib64/libfontconfig.so.1
#6  0x0000003fa281b975 in FcInit () from /usr/lib64/libfontconfig.so.1
#7 0x0000003fa2812cab in FcConfigGetCurrent () from /usr/lib64/libfontconfig.so.1 #8 0x0000003fa2814d2b in FcConfigSubstituteWithPat () from /usr/lib64/libfontconfig.so.1 #9 0x0000003fa4f067d0 in pango_cairo_fc_font_map_get_type () from /usr/lib64/libpangocairo-1.0.so.0 #10 0x0000003fa4b098ea in pango_fc_font_map_get_type () from /usr/lib64/libpangoft2-1.0.so.0 #11 0x0000003fa4d14c1d in pango_context_get_font_description () from /usr/lib64/libpango-1.0.so.0 #12 0x0000003fa4d14f3d in pango_itemize_with_base_dir () from /usr/lib64/libpango-1.0.so.0 #13 0x0000003fa4d1c0e0 in pango_layout_iter_get_char_extents () from /usr/lib64/libpango-1.0.so.0 #14 0x0000003fa4d1cc28 in pango_layout_iter_get_char_extents () from /usr/lib64/libpango-1.0.so.0 #15 0x0000003fa4d1db66 in pango_layout_get_pixel_extents () from /usr/lib64/libpango-1.0.so.0 #16 0x00000000004203c2 in myScreenInit (display_info=0x560400, gscr=0x558120, event_mask=7995436) at screen.c:79
#17 0x000000000041a368 in main (argc=Variable "argc" is not available.
) at main.c:404
#18 0x0000003fa0f1d084 in __libc_start_main () from /lib64/libc.so.6
#19 0x0000000000408819 in _start ()
#20 0x00007fffffbdee78 in ?? ()
#21 0x0000000000000000 in ?? ()
(gdb)

I really appreciate all this help. I'd never have figured out how to get this far.

sean


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]