[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: '-Wunused-param' in kernel compiles?



On 4/5/06, Tom London <selinux gmail com> wrote:
> On 4/4/06, Bojan Smojver <bojan rexursive com> wrote:
> > Have you tried any of these:
> >
> > http://ftp.cvut.cz/vmware/
> >
> > For instance:
> >
> > http://ftp.cvut.cz/vmware/vmware-any-any-update101.tar.gz
> >
> > PS. I haven't tried VMware on current Rawhide yet, so the kernel API
> > may have been changed again to the point where the above patches don't
> > help.
> >
> > --
> > Bojan
> >
> Yup, tried the above, and still fails.
>
> Messaging with Petr (@vmware) is suggesting the '-Wunused-param' path.
>
> I'm still digging....
>
OK. Here's what I've figured out....

The vmware 'configure' system (vmware-config.pl) attempts to
auto-configure by compiling small 'test' programs and detecting
success.  It uses '-Werror'.

Since the recent kernel builds include '-Wunused-param', this makes
this break.  (Seems a bit fragile to me; there should be a better
way....)

Anyhow,  the resulting failed compiles cause some significant
compile-time parameters (e.g., VMW_HAVE_EPOLL) not to be set
correctly.

Removing the '-Werror' from the makefiles (thanks to Dave Jones for
the hint!) allows vmware-config.pl to complete (spewing lots of
warning messages, but completes). I can now startup vmware (didn't
connect to sound hardware, but rest seems OK).

I'm guessing that when -Wunused-param is removed from the kernel
builds, this will settle.

I'll try to get VMware folks to ponder this, but I suspect we're on
our own until -Wunused-param reverts.

tom
--
Tom London


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]