[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing system config tools?



On Fri, 2006-04-14 at 15:30 -0600, Lamont R. Peterson wrote:
> On Friday 14 April 2006 02:40pm, Callum Lerwick wrote:
> > On Fri, 2006-04-14 at 20:27 +0200, Nicolas Mailhot wrote:
> > Errr. Do you mean moving an LV to another PV? As in using pvmove? I had
> > rather serious system eating (but ultimately recoverable) problems with
> > pvmove when I moved my system to LVM using an FC5 rescue disk. It may
> > not just be system-config-lvm. For no reason I could figure out, about
> > half the time pvmove would crash and totally eat the PV metadata.
> 
> Since you were in a rescue environment, did you activate the Volume Group 
> (VG)?

The first pvmove I did, no they weren't. I figured the lvm tools are
smart enough to tell me if it was the wrong thing to do. And it ended up
crashing and burning. So the next time around, I did it with the LV
activated. It happened again. So I don't think that's it.

I suspected it might have been the fact I used --metadatacopies 2 with
pvcreate, because when I rewrote the PVs with the default it worked. But
on a second pvmove it crashed and burned again. So I don't think its
that either.

I tried it with both an i386 and an x86_64 rescue disk. Didn't make a
difference.

It honestly seems to be completely random.

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]