[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Xorg signal 11's spontaneously



Adam Jackson wrote:
Dennis Jacobfeuerborn wrote:
Dennis Jacobfeuerborn wrote:
In the last 10 days Xorg crashed three times with a signal 11 spontaneously. This is the backtrace I found in the logfile:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x87) [0x80b6d07]
1: [0x49a420]
2: /usr/lib/xorg/modules/libfb.so [0x134b81]
3: /usr/lib/xorg/modules/libfb.so [0x13c80c]
4: /usr/lib/xorg/modules/libfb.so(fbCompositeGeneral+0x855) [0x13a4e5]
5: /usr/lib/xorg/modules/libfb.so(fbComposite+0x1cd) [0x1433ad]
6: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x261) [0x81f001]
7: /usr/bin/Xorg [0x8156d06]
8: /usr/bin/Xorg [0x8153915]
9: /usr/bin/Xorg(CompositePicture+0x153) [0x8140a13]
10: /usr/bin/Xorg [0x814687c]
11: /usr/bin/Xorg [0x8143bd5]
12: /usr/bin/Xorg(Dispatch+0x19a) [0x80869ba]
13: /usr/bin/Xorg(main+0x485) [0x806e3e5]
14: /lib/libc.so.6(__libc_start_main+0xdc) [0x4cd7e4]
15: /usr/bin/Xorg(FontFileCompleteXLFD+0xbd) [0x806d721]

Fatal server error:
Caught signal 11.  Server aborting

All three crashes happened when I was loading a page in Firefox and after the nightly Firefox builds got switched to Cairo as their rendering backend so I wonder if Cairo could somehow trigger this.

I'm running Fedora Core Rawhide with the following Xorg packages:
xorg-x11-server-Xorg-1.0.99.901-5
xorg-x11-drv-nv-1.1.1-2

I'm using the open source nv driver with the AccelMethod set to EXA and the 'load "dri"' and 'load "glx"' lines commented out.

Neither DRI nor EXA matter at all to the nv driver, which supports neither.

Just happened again and the backtrace looks similar to the one above. If I can do something to provide better information to debug this please tell me.

Install the debuginfo packages, ssh in from another machine, su, attach gdb to X, 'handle SIGPIPE nostop', and 'cont'. When the server segfaults, 'bt f' should now give you useful backtrace info.

I filed bug 6704 about this in the fdo bugzilla and there someone pointed me the appropriate wiki page for debugging the X server. Since I don't have a second machine nearby right now I'll try the single machine approach described in the wiki.

May also be related to a crasher recently fixed for x4a4 glyphs; I'll backpatch that into rawhide and stable shortly.

Is there a way to deliberately trigger that bug? I haven't found a way to trigger the crash I'm seeing but if the glyph bug would result in the same backtrace as above then we'd know if this is really the same problem. Right now I've set the NoTrapSignal option and enabled core dumping and now have to wait until X dies again.

Regards,
  Dennis


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]