[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [BUG] yelp depends on mozilla?



Nicolas Mailhot wrote:
Le dimanche 30 avril 2006 à 11:33 +0100, Keith Sharp a écrit :

There has been a relatively recent discussion on this:

https://www.redhat.com/archives/fedora-devel-list/2006-April/msg01195.html

I didn't follow the entire thread, but I believe the long term plan is
that applications needing an HTML rendering component will switch to use
Xulrunner:

	http://developer.mozilla.org/en/docs/XULRunner

When this is scheduled to happen I do not know.

Don't get your hopes too high, having a sane shareable mozilla HTML
rendering component has been a goal since before firefox existed.

One has to wonder after all this time if the moz code is not too badly
designed for it to ever happen.

There are good news about this, it's finally happening. XULRunner 1.8
works pretty well (I actually made some experimental rpms). Yelp,
epiphany and the other gtkmozembed applications should run just fine
with it.

I think running firefox on the top of xulrunner requires 1.9 though
(which will be released 2007 Q1).

Marco



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]