[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpm: rpmte.c:589: rpmteColorDS: Assertion `ix < Count' failed.



Hi,

I have been hit by above message for some time now while trying to upgrade
glibc. This issue was already mentioned back in may with the advise to first
upgrade to the latest rpm.

Upgrading to the latest rpm fails on the rtld(GNU_HASH) dependency...

But I still wanted to upgrade to the latest glibc to for example install the
latest rawhide gnucash.  So I forced the rpm upgrade using the --nodeps.
That worked but rpm now gives segfaults, as could be expected. 

Now I manually ugraded to glibc-2.4.90-17.i686.rpm (by using rpm2cpio and
manually copying the tree to the root/usr partition while running from a
rescue CD).

The system is now running fine again and rpm does not segfault anymore. So
I again tried to upgrade glibc using rpm (to update the rpm database) but
still the assertion failure appears.

I'm lost... Anyone know how to get this fixed without reinstalling the
whole system?

Thanks,

-Marcel
-- 
     ======--------         Marcel J.E. Mol                MESA Consulting B.V.
    =======---------        ph. +31-(0)6-54724868          P.O. Box 112
    =======---------        marcel mesa nl                 2630 AC  Nootdorp
__==== www.mesa.nl ---____U_n_i_x______I_n_t_e_r_n_e_t____ The Netherlands ____
 They couldn't think of a number,           Linux user 1148  --  counter.li.org
    so they gave me a name!  -- Rupert Hine  --  www.ruperthine.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]