[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: kernel: broken qla support



On Thu, Feb 02, 2006 at 02:56:14AM +0100, Tomasz Kłoczko wrote:
 > 
 > More than few kernel package version ago was broken support for all Qlogic 
 > cards. This ahppens because someone was disable all CONFIG_SCSI_QLA* in 
 > .config.
 > 
 > [root boss boot]# diff -u config-2.6.14-1.1773_FC5 config-2.6.15-1.1884_FC5 | grep QLA
 > -CONFIG_SCSI_QLA2XXX=m
 > -CONFIG_SCSI_QLA21XX=m
 > -CONFIG_SCSI_QLA22XX=m
 > -CONFIG_SCSI_QLA2300=m
 > -CONFIG_SCSI_QLA2322=m
 > -CONFIG_SCSI_QLA6312=m
 > -CONFIG_SCSI_QLA24XX=m
 > +CONFIG_SCSI_QLA_FC=m
 > +# CONFIG_SCSI_QLA2XXX_EMBEDDED_FIRMWARE is not set
 > 
 > On my system without loading qla2300 isn't possible scan avalaible LUNs.

In 2.6.16rc, CONFIG_SCSI_QLA2XXX_EMBEDDED_FIRMWARE is marked as deprecated,
which means at some point it's going to go away completely.
The help for that option states..

	This option offers you the deprecated firmware-loader
	modules that have been obsoleted by the usage of the
	Firmware Loader interface in the qla2xxx driver.

But I realise now this means that right now, we aren't shipping
the firmware at all with this disabled.  I'll have a talk with
the upstream people responsible, and see what the plans here are.

Can you file a bugzilla on this so that it doesn't get lost, and
make it block on FC5Blocker please ?

		Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]